Getting Started

User Interface

ASTERIX Analyzer has a modern and easy to use user interface. The main window composes of menu bar, tool bars, status bar and main view.

All functions can be accessed through main menu, and major fuctions can be accessed through tool bar.

ui_main_window.png
Main Window
Detailed infomation of user interface can be accessed at chaptor User Interface.

ASTERIX Step by Step

A typical way of using ASTERIX Analyzer is to open and analyze data in recorded file. Below is an example to show how to do it step by step.

STEP 1. Prepare file with ASTERIX data

ASTERIX Analyzer supports different File Formats.

You can use the Data Recording and Playback tool to record and generate recording files. You can also use common tools like Wireshark or tcpdump to generate recording tiles.

Here, assuming we already have a data file named "radar.rex".

STEP 2. Open and load file

Launch the ASTERIX Analyzer application, select File -> Open File..., a standard Open File Dialog will appear.

Browse and select our data file "radar.rex".

In the left panel in main window, many data packets contained in the data file will be shown. A sequence number, time stamp, and size of data packet will be displayed.

In the title bar, the file name will be displayed.

stepbystep_open.png
File Loaded
If you don't need to load all packets contained in the data file, you can select File -> Stop Processing to stop the file loading process at any time.

STEP 3. Decode data

If the data packet contained in data file use default frame type (no frame) and default UAP (ASTERIX standard UAP), you can simply select one data packet, and the data block/record/item will be shown in the middle panel. Also the radar data of this packet will be shown in hex format in the top-right panel.

stepbystep_decode_packet.png
Select Data Packet
If you select any data record or data item in middle panel, the detail of this data record/item will shown in the bottom-right panel. Also please note the data of selected data record/item will be highlighted.

stepbystep_decode_item.png
Select Data Item
On the other hand, if data packet is not in default frame type and UAP, it can not be correctlly decoded before you select correct one.

You can select View -> Frame to select frame type, and select View -> UAP to select UAP.

stepbystep_decode_frame.png
Select Frame Type
stepbystep_decode_uap.png
Select UAP
For UAP, if Auto UAP is selected, ASTERIX Analyzer will try to guess what is the correct UAP and try to decode data with it, but sometimes it may fail and select a wrong UAP, in this case you should manually select a proper UAP and force the system to decode data with selected UAP.

STEP 4. Inspect data

Once data is correctly decoded, you can use Tree View and Track View to inspect the detail of ASTERIX data.

STEP 5. Find data with filter

Normally, you will receive a plenty of data packets from a sensor even in a short time.

And a tapical task to analyze ASTERIX is to find flights match some specific conditions. For example, flights with hijack alert. You can do this in an easy way by using the Filter function.

Here we try to trace flight "KTK2422". Type "callsign = KTK2422" in the filter toolbar, and press Apply, packets contain flight "KTK2422" will be shown in the UI.

stepbystep_filter_treeview.png
Flight KTK2422 in Tree View
stepbystep_filter_trackview.png
Flight KTK2422 in Track View
For advanced use of Filter function, please refer to chaptor Filter.

STEP 6. Export data

Once you had find some data you are interested, you can then export and save it in other formats. Here we export the historical data of flight "KTK2422.

Select File -> Export Track List as CSV..., a standard File Save Dialog will appear, you can browse and save track list as a CSV file.

Later, you can use Microsoft Excel or other compatible application to open and edit this file.

stepbystep_export_csv.png
CSV File in Microsoft Excel
Similarly, you can export datil ASTERIX fields to Adobe PDF format, and view/print it with "Adobe Reader* or other compatible application.

stepbystep_export_pdf.png
PDF File in Adobe Reader